How to upgrade an app from V2 to V3?

Hello, I haven't been working with Andromo since few months ago. Now I want to know how to upgrade an from version 2 to version 3, please

Comments

  • Here's what andromo advised:

    Since the new V3 builder is much more functional than the previous one, there is no sense to migrate projects between them. If you want to upgrade an app from V2 to V3:

    1) Create same but BETTER app at V3

    2) Give it the package name of the app you want to ''migrate''

    3) Put a tick in the box "Use andromo key to sign" in your app Settings

    4) Update it at Google Play

  • 3) Put a tick in the box "Use andromo key to sign" in your app Settings

    4) Update it at Google Play


    Just tick in the box? Andromo will detect the package name of the app when build the new app?

  • Too bad those instructions don't actually work for any app that uses things in V2 that are not available in V3.

  • Hi the instruction provided by Andromo is not helpful. Is there any video tutorial on how to migrate v2 to v3?

    I can't find "3) Put a tick in the box "Use andromo key to sign" in your app Settings" in v2 Setting tab. The option is only available in v3.

    If I create a new app in V3, I can't even edit the package name to use existing name. Also, this isn't called 'migration' if I had to create a new app from scratch in V3. Please advise.

  • @RaaiqApp TrevorH cForget about the word Migration from V2 to V3, You only have to create the app from scratch Then "tick in the box "Use andromo key to sign"

  • How can I migrate an existing app from V2 to V3? I can't manage with the instructions? here.

    Are there any instructions for this?

    How do I find out in advance whether all features are available in V3?

    Are there any restrictions regarding the payment plan?

    I currently have the Starter Plan.

    When I asked when V3 would be available for the Starter Plan, Support told me that the Starter Plan would not be available for much longer.

    In the current pricing model, I now find Hobbyist, is this comparable?

    Do I have to become active here myself, or can it not simply be changed?

    I'm missing useful information from Andromo again!

  • @DigitalInnovationsAfrica I understand that. The problem is that v3 doesn't yet have all the features I need from v2. So I can't create the same apps from scratch in v3.

  • @TrevorH Me too I am having the same issue but the support is just playing around, Failed to work on facebook bidding and online audio player.

  • after following the above instructions and update the v3 app in developer console, it is saying as "You can't rollout this release because it doesn't allow any existing users to upgrade to the newly added app bundles."

  • MyDen

    It seems that all your tickets are closed at the support. Don't hesitate to contact support@andromo.com in case you have issues, and we will be glad to assist you!

    Regards,

  • Currently, your application's target API level is 29, but it should be at least 30 to ensure that it compiles with the latest APIs, which provide optimal security and performance. Change your application's target API level to at least level 30. 

    if there is no solution to this then I want a refund

  • I have the same issue so how to fix it?

  • You have to build in v3 and set the package name to be the same as it was in v2 in order to allow upgrade (build number also has to be at least 1 higher than v2).

Sign In or Register to comment.