To participate, please log in to your Andromo App Maker account then come back here!

AdMob banner ads not showing?

edited September 2014 in General Discussion
I've just noticed that in one of my apps the AdMob banner ads are not showing. However, everything is set up correctly in Andromo, and I also see impressions in AdMob web console for the banner ads (up to 23rd of September, today's stats are not in yet).

I've asked my friend to install the app to see if he sees the ads and nothing. The interstitial ads work, but no banner ads.

What could be wrong? Did anyone experience this?

Thanks.

EDIT: On a side note - if I remember correctly, someone here said that he lost his AdMob account, because too many of his own ads were displayed to him (probably when he was making/testing the app). AdMob now also allows CPM bidding, so viewing our own ads is somewhat like clicking on them, I suppose. That's why it would be good, if Andromo could consider implementing something like "test devices" - more about that here: http://stackoverflow.com/questions/18584750/significance-of-admob-test-device-for-android
Tagged:
Tagged:

Comments

  • My Admob banner not showing too...
    Plz show me the true sample AdMob Ad Unit ID :(
  • I still don't see the ads, but the impressions are there in the AdMob console, so I suggest you log in to AdMob and see if your ads unit is active.
  • @hendrixs did you find out what was going on with the banner ads? If it still happens, are there any clues in the logcat output?

    A list of test device IDs is a good suggestion; we've used a list like that internally from the start and have always thought it would be a good thing to expose to users. I'll send an email to the rest of the team bumping it for consideration again.
  • @lorne: Still no banner ads in the app when I or my friends view it, but the impression count is normal in AdMob. Have no idea what's wrong. Sorry, but I don't know what logcat is.

    Thanks, that would be a nice feature to have. Another extra step for protecting the AdMob account.
  • Would you mind telling us which activities you had in this app?
    Maybe it is possible to recreate the error with specific activities/settings?

    I also used the have an app with this problem (had html activity, pdf and podcast) a while back.

    Got it solved by adding another ad unit on admob and changing the ad unit number in the app.
  • Hey @sylviathewitch, the app uses sound board activities only.

    It's confusing because I see the ad impressions on AdMob for the banner ads. Thanks for the tip - I'll probably assign a new AdMob ID when I update the app next time.
Sign In or Register to comment.