AdMob Ads Not Showing: Nov 6

edited November 2014 in General Discussion
Anyone having issues with Admob Ads not showing?  ( neither banners nor interstitials)
-Ad Units are active in my Admob Account
-Ad Unit IDs and check-boxes are properly executed in Andromo
-AdMob shows activity & earnings for today

but Ads not showing up in any of my many apps on my Samsung Galaxy Nexus.

Any clues



  • Check in AdMob's web interface if impressions are shown. I too don't see my own banners ads in some apps, but the impressions are there in AdMob.
  • @Hendrixs
    -thanks for your comment.
    -yes, checking AdMob was the first thing I did - and impressions are showing ( see comment above)
    -also, when I run the apk through an Android emulator, the ads do show up  / but just not in my phone.
    -I can only assume now that it has something to do with my Samsung Galaxy Nexus settings - maybe the new Google Ad ID or something
    -I'll post again when I get to the bottom of this

  • @amsico: Please let us know what's the cause, once you figure it out. You can at least see the ads in emulator - mine don't work anywhere I test them, but friends from abroad confirmed, that the banner ads work.
  • @Hendrixs
    -well I solved it ( for my phone at least !)
    -my apps only show admob ads when WIFI is enabled
    -I had turned off WIFI over the past few days and forgotten to turn it back on.

    Now, I don't know why the heck that should be, but that is the case.  If I turn off the WIFI, then no ads again.

  • @amsinco: I'm happy to hear you figured it out! For me it's the same - I don't see the ads on WiFi or mobile connection. But, the number of impressions is OK, so I don't worry too much. :)
Sign In or Register to comment.