To participate, please log in to your Andromo App Maker account then come back here!

One of my apps gets a "not designed for tablets" message on GP

edited June 2015 in General Discussion
I have an app which extensively uses the HTML Archive activity (custom HTML/CSS) and after uploading the updated APK, I got this message next to my graphics assets:

"You uploaded screenshots for 7-inch tablets, but your APK does not seem to be designed for 7-inch tablets." (it's the same for the 10-inch tablets)

In "What should you do" it says:

Your Production APK needs to meet the following criteria:

imageYour layout should make use of the available space on tablets. Learn more

I use the "List" dashboard type with 10+ activities.

Did anyone else experience this?

Comments

  • It depends whether the message is caused by an automatic check or a manual one. If it was automatic, it may be based on complex analysis of the layout, or (more than likely) it may be something as simple as whether or not a Fragment was used.

    One way to test that might be to see if the same message pops up for an app built around the Photo or RSS feed activities, which are some of the activities that do make use of fragments.

    We've always tried to consider tablets when designing Andromo, but to date we've tried to limit the amount of layout specialization (although we do use different layouts for tablets and phones to some extent). This is partly for technical reasons, and partly because we felt it would be difficult to do much better without having more information about the specific purpose of each app.

    Even so, making Andromo take more advantage of tablets in general has been a long-term goal of ours for a very long time, but it's proven hard for it to bubble up past other things that are given higher priority.

    I am hoping to take some steps in that direction with the material design update, though.

  • @lorne:

    Thanks for the info. The message was automatic as I got it immediately after uploading the APK. However, this is the first of it's kind and I've been using Andromo since mid-2012. Also, the funny thing is that I didn't changed anything - I just rebuilt the app and updated it.

    I'll leave it as it is for a month or so and then try again.
Sign In or Register to comment.