To participate, please log in to your Andromo App Maker account then come back here!

Action bar not accessible when Dashboard=none

I am making an app that opens directly to an activity, so I've made dashboard=none, and the activity I want is the one on top of the activities list.

It works,  the app opens directly to the activity, but then I cannot get to the other activities through the action bar (the action bar does not show options when you touch it).  I've tried renumbering the activities list so they don't all have the same number (although the one on top was already the one I wanted), but no change in the results...

This is the first time I use dashboard=none, what am I getting wrong? Is this the correct way to do it?

Comments

  • More info: I've tried the same app using a list dashboard, and still the action bar does not show options.

    I've then checked my previous apps, and found that the action bar does work except in one; the common pattern could be that they both use the photo gallery activity.

    Is this a known issue? Is there something I can do?
  • I wasn't able to replicate any issues, so the first thing you should check is what setting you have configured for  "Action Bar Mode" in the Action Bar section on your project's Styles tab. That setting controls whether or not navigation is shown on the action bar. You should have the "full navigation" option selected if you want the dropdown.

    So check to see what you have there.
  • Hi, sorry it took me time to get back

    The option in Action Bar Mode says "show activity name (full navigation)". I rebuilt the app and tested it again just in case. Still no options appear.
  • Hi,

    What I'd suggest is to submit this issue to our support section and list the name(s) of the projects where you're seeing this so we can look deeper at the content of your project in order to try to replicate the issue. You can access our support by going to Help > Technical Support from your Andromo account.

    Darryl
  • OK, thanks, I'll do that :)
Sign In or Register to comment.