To participate, please log in to your Andromo App Maker account then come back here!

Why aren't I seeing my changes?

I've been trying out Andromo since yesterday. I made some changes this morning - they came through ok and I tested it.
I made some more changes early this afternoon - build - email - install - but nothing had changed, it was the same as this morning.
I tried again later this afternoon - more changes - build - email - install - but again nothing -  the app was the same as this morning
I tried uninstalling and then installing the new app - no, still the same as this morning.

I checked the sizes of the apk files and they are different - so I would think the build is working ok.

Maybe my phone has cached a copy of the installer from this morning?
Any thoughts on how I can fix this?

Comments

  • First, make sure the old version is getting uninstalled. The best way to do that is to uninstall the old version, and confirm that it is no longer listed in the apps on the device. (It's technically possible for two apps with the same name but different package names to overlap, although it's not something you would ever run into unless you're changing the package name each time you build.)

    On the website, make sure you remember to click "Save Changes" on a page after making any changes. This is easy to forget, and depending on the browser the settings can end up cached for a bit so it looks like you made the changes you wanted -- but they don't get committed to the database unless you click the "Save Changes" button. So always click "Save Changes" after making any changes.

    Then, make sure you're installing the new version. If you're installing from a PC using the adb command it helps to rename the .apk files after you download them, for example to include a version number in the filename -- something to make it clear to yourself which file is the new version. If you're installing directly from the emails, be careful that you are actually downloading the new version (you need to expand the newer email to see the download link, etc.). You might want to clear out the previous .apk files from the "Downloads" on the device first, so there's no confusion about which .apk file is the new one.

    Lastly, it could be that you are making changes that don't change the look of your app. For example, if you're changing colors and settings on the Theme tab, those changes will only apply to things that are using the "Global" theme settings. If your dashboard and all your activities are using "Custom" then changes to the global theme won't have any visible effect.

  • Create Your Own App with Andromo


  • edited October 4
    I should add that it isn't technically necessary to uninstall the old version before installing a new version; just like when an app is updated, downloading the new version and installing it over the old one should work. I will often just install a new version right over the old one when testing changes.

    However, uninstalling the old version first will make sure the app starts up with fresh settings, and won't be affected by data in the app's cache from other times it was running.

  • Thanks Iorne - that's all really useful.

    In the end I restarted my phone and that seemed to fix it - I guess something had just got "stuck" somehow - but maybe that will help someone else who has the same problem.

    Thanks again for your advice.
  • A reboot fixes everything. :)
Sign In or Register to comment.