Google Analytics

Can someone please help me with getting Google Analytics working?

But, when I open Google Analytics I see no traffic at all. What am I doing wrong? 


  • Make sure you choose to track a "Website" and not an "App". Somehow it doesn't work with the App option
  • Thank you for the help. 

    I have done that I think and still nothing. This morning I have deleted my profile in Analytics, and added a new profile with the info, and still nothing. Made sure I did Website instead of App, but still nothing. 

    I just tried again. This time I created a whole new account with Analytics, used the example fake website shown in the directions, created a property and a profile under the property, etc... and still nothing. In Analyitics, under my property, Tracking Info tab, it shows Status: Tracking Not Installed.

    It seems the directions at are not current. So, to double check, in my app under the marketing tab, for Analytics Code, it is looking for just the Property ID:UA-xxxxxxxx-x, right?

  • edited March 2013
    Right, just enter the number such as:

    The quickest and easiest way to test it in my opinion is to open the app on your phone, use your desktop/laptop/tablet and go to the section in Analytics:
    Standard Reports>Real-Time>Overview

    You should see yourself browsing through app activities in analytics within a minute or less.  It gets fun to watch when you get 15 or more people on.  You really get a sense of what people are using the app for mostly.  Good stuff. :)

  • Thank you for the help.

    I did get it working some. What finally worked was to not put in the UA- part, but just the numeric part of the code. Now it works, shows visits and such. 

    But, it seems to be spotty at best. Right now it is showing the last visit was Saturday. Even though I have been on the app lots yesterday and today. And the Real-Time doesn't work at all.

    I don't know what I'm doing wrong.....
  • edited March 2013
    I'm not convinced you are doing anything wrong.  Could be a bug.   I know you probably tried everything I'll address and suggest trying below... but just in case. :) 

     All of my apps use the UA part included, exactly like my example above.  I've never tried it without UA-, but it probably doesn't matter.  

     The analytics is somewhat limited because we are using it as a web page instead of an app, but Real-time should have worked. If you click on real time, be sure to then click on "Overview" just below it or one of the other options, location etc.  Clicking real-time alone won't display any live results if i remember correctly. 

    As far as it showing the last visit was Saturday, you might double check the date settings because by default I think it lags 1 day behind unless you specify a date range to include today's date.  Also, consider yourself counted only 1 time per day as normal analytics behavior.  It probably checks cookies, ip address, etc. to confirm that you are indeed a new visitor that day.  I can use one of my apps 20x a day and only get counted 1x per 24 hrs.

  • I have indeed tried all that. But, thank you for the help.

    I didn't know about that last part, but ever since creating a new property and profile and getting a new ID yesterday I have zero activity. And, to make sure I just double checked in my app that I did indeed update with the new property ID, and rebuilt it just now. 

    It doesn't seem to matter what I do I cannot get the Real Time working at all, actually nothing works right now.

    In the spirit of trying everything... do I need to set any profile filters?
  • edited March 2013
    I've never touched profile filters, so it should be fine as is.  You could attach some screen shots of your settings within Andromo and Google Analytics here.  Sometimes it helps to get some fresh eyes looking at it. :)  (Make sure the GA check box is still enabled within andromo etc)

    Other things that might cause problems... the possibility that you are sitting behind some crazy strict firewall or other program that is masking/hiding your internet activity (essentially making you anonymous/invisible/impossible to track).  Your IP or internet activity could be somehow blocked/hidden at either at your end or your ISP.   A very long shot, but just putting it out there.

    I also wonder if GA is available to use in all countries and what country are you using your app from?

    You could attach your .apk here or link us to it on Google Play and I'd
    be happy to test/poke around in it.  Maybe you would see it logging
    my activity.

  • Mike, thanks for the reply. 

    I've been out of the country for a week or I would have responded sooner. 

    Here are screenshots of my settings. If there is any particular screen I have missed, let me know and I will get you a screenshot of that as well. 

    GA has finally started working, except for Real-Time. The app I built is for listening to a Shoutcast radio. Last week I was in Mexico for a week long meeting and was broadcasting every day live. Logged into my CentovaCast server I was able to see that I had at least 10 listeners on the App just about every service. But, looking in GA Real-Time it would maybe show one or two, once showed four, but usually showed zero, even though I knew I had about ten. 

    It may be as you say that the ISP or whatever was blocking the Real-Time, but since it won't work at my home in CA, I doubt that is it.

    Any help you can give will be greatly appreciated.

  • edited March 2013
    The first thought that came to my mind is the possibility that because they are listening to a stream, their device's screen powers down and makes them appear to have left the app.  
  • Our current implementation of analytics only sends a hit when the user arrives, it doesn't track the time spent viewing an activity or anything like that. So the realtime graph will only show a blip whenever someone arrives.

    We're actually switching to a newer version of analytics in the near future which will let you use the full app analytics instead of tracking your app as a web site.
  • Good to hear about the improved tracking on the way.  Keep up the good work!
  • Yes, good to hear. Looking forward to that. 

    Thank you for a great product.
Sign In or Register to comment.