To participate, please log in to your Andromo App Maker account then come back here!

Podcast Activity Broken?

edited December 2013 in General Discussion
I am trying to use the podcast activity but its only loading the last 15 or so on the RSS Feed. Using the exact same URL every other RSS reeder/podcast app loads up 200+ episodes. Any idea what could be keeping it from loading. It also looks like the app is just loading and loading.

Thanks

Comments

  • Couple thoughts:
    • are the missing episodes video files? Only audio podcasts are supported.
    • how many items does the RSS feed currently contain? It could be that those apps are caching episodes that they received from the feed in the past.
  • @Lorne thanks for the response, but no the missing episodes are all audio. The RSS feed has over 250 items. The app only loaded about 15 last night when it originally posted, now it has loaded about 120, but still not all. The other thing is the loading spinning circle in the action bar has not stopped moving. It seems like its loading them all, just very very very slowly. Again I dont think its a problem with the Feed, my regular Podcasting app loaded them all up (not cached or anything) in just a few seconds. Anything I can do to optimize this?
  • edited December 2013
    Hmm, that makes it sound suspiciously like it's not getting correct XML from the feed. What is the feed URL?

    What is the size of the XML? Are there very large descriptions within the feed? It could be above the download limit we've set for feeds, which could cause the XML to be truncated and result in much of it being uninterpretable.
  • I seem to be having a similar problem. The podcast feed no longer loads at all.
  • @syxxfiggaz

    > I seem to be having a similar problem. The podcast feed no longer loads at all.

    This was due to the server not accepting the user-agent string in the HTTP request. A workaround has been added in 3.3.0 that permits several different user-agent strings to be tried.

    @happypizza

    I haven't been able to duplicate this behaviour. What is the URL of the feed you were using?
  • @lorne

    It wasn't the feed, it was a mistake on my part. Everything is working well now. Sorry, I should have updated the post to reflect that.

    Thanks
  • Ah, thanks for responding happypizza that's really good to know.
Sign In or Register to comment.