To participate, please log in to your Andromo App Maker account then come back here!

Do we need to resubmit apps on Amazon for Fire HD 6/7 support?

edited September 2014 in General Discussion
Hello,

I was updating one of my apps today, and I saw new "Device Support" options in the Binary Files tab. The newly available devices are Fire 6 and 7 (4th Gen).

Both were checked by default so I just submitted the app. What about the old apps? Do wee need to update them if we want our apps to be available on all Kindle Fire devices?

Thanks.
Tagged:
Tagged:

Comments

  • Anyone, please? :) Hm, I might also ask the Amazon support and share the answer here.
  • Hi Hendrixs,
    Yes you need to update the apps for them to be available on 4th Gen devices.
    I checked one of my apps ("current version" ---> "Binary" ---> "Device Support") and the 4th Gen does not show up.

    "All non-Amazon Android devices based on my manifest, Kindle Fire (1st
    Gen), Kindle Fire (2nd Gen), Kindle Fire HD 7 (2nd Gen), Kindle Fire HD
    8.9 (2nd Gen), Kindle Fire HD 7 (3rd Gen), Kindle Fire HDX 7 (3rd Gen),
    Kindle Fire HDX 8.9 (3rd Gen)"

    As far as I remember it was the same with the 3rd Gen devices.
  • Hey @sylviathewitch, thanks for the info. :) Will start updating over the weekend.
  • You might want to wait. When I've updated apps the last few days, they've been approved for all but the new devices, with a note saying they aren't testing for them yet.
  • FYI
    4th Gen devices are now tested when submitting a new app/updated app.
    Just got approval for two apps, that I have submitted yesterday.

  • Thanks Sylvia - Good info!
  • Thanks, Sylvia! I too just received an email confirming that my newly submitted/updated apps are compatible with the latest Kindle devices.
Sign In or Register to comment.