To participate, please log in to your Andromo App Maker account then come back here!

Shoutcast activity not working

i used the Shoutcast activity for my app yesterday: http://192.99.13.189:9360 is the URL which did not come, except showing buffering through.
I earlier tried http://192.99.13.189:9360/ which also shows buffering and came after more than 5 minutes.  So what do i do now, because the streaming server works fine on the client's website, but refusing to load in the app. i tried the pls option too and it did not work. in need urgent help. thanks


Tagged:

Comments

  • edited October 11
    I suspect the link you gave actually ends up with something like stream.pls or mp3.pls
    What is the station's name exactly? I could try to help you. I have some resources to find the right station link.

    EDIT: Try http://192.99.13.189:9360/;
    Include the semicolon





  • Create Your Own App with Andromo


  • hi, thanks for the feedback. I tried the ; but still i see the buffering and no sound. Strangely, it shows the song being played when you check the music icon at the taskbar at top of the phone. So there is some connection being made to the shoutcast server, but the sound is not working.

    It is not a station listed on shoutast directory. It is a church online station we just set up. but it works fine on their website. Gloryhope.org .
    So i am very confused becasue i tried built another app lasy night , and had only the shoutcast as the activity, and the problem is the same in that too.
  • Are you using the Shoutcast Playlist? Also, did you wait a bit longer on the buffering? Because sometimes the music delays to start.
    The link should be OK, I double checked in the website too. Maybe they try to set it up in mp3?
  • edited October 12
    1. NO i am using normal streaming not the playlist.
    2. My last attempt at listening, the buffering took over 20 minutes, which of course is not normal at all.
    3. The website is playing auto DJ now. so it streams fine when listening at the site and even on your phone from from the site.
    4. If you dont mind, you could test it for me.


    Thanks for the effort so far.

  • edited October 12
    I tried your app and I also added the station in one of my apps but still it will not work.
    I am not that good understanding logcat, but I ran it on your app and there are two possibilities.
    One is, the station is on aac and andromo supports only mp3 (I am not even sure if aac is supported)
    The second is, I saw a warning that the client refused the connection.
    Anyway, try reach to andromo support for them to help you better. Also consider asking the owner if they can switch their broadcasting to mp3.

  • thanks for help so far.
    The streaming is shoutcast mp3. Strangely, the sound can come but after waiting on buffering for over 20 mins or sometimes wont come at all. I cant locate the support email to use to reach anfromo. thanks

  • edited October 12
    http://support.andromo.com

    Using mp3 would be more compatible with more devices than aac. Likely Either your connection is slow or you are streaming a very low bitrate that takes a long time to fill the Android buffer. Increasing the bitrate of the audio will help that.
  • it is mp3 and streaming 64kbps, which i believe is reasonable
    thanks for the help
  • Andromo supports AAC if it's supported on the device. Some devices make changes to the Android audio framework that breaks things or adds bugs.

    There is also an annoying "feature" of the Android audio framework that it uses very large buffers, which must be filled before playback can begin. The bitrate of the stream and the network speed both affect the rate at which these buffers can be filled -- so lower bitrate MP3 files can actually take a very long time to buffer before playing will begin.

    You'd think lower bitrates would be quicker/easier to play, but they actually make buffering take a VERY LONG time.

    I'd suggest changing to a higher bitrate if possible.

  • Not at all. it is mp3 and at 64kbps.
    My connection is broadband so very fast.
    thanks

  • Create Your Own App with Andromo


  • edited October 18
    Note that a 64 kbps MP3 can take a while to buffer before playback even on a fast connection (and several minutes on a somewhat slower connection).

    I'm happy to see that this was resolved in support -- it turned out to be an issue with the stream being automatically transcoded to AAC+ on the server. AAC+ although officially supported on newer models doesn't actually work on all Android devices.
Sign In or Register to comment.