To participate, please log in to your Andromo App Maker account then come back here!

Andromo App Maker for Android v5.0.16 Released

Andromo App Maker for Android version 5.0.16 has been released.

Here is a list of changes in this version:

  • Fixed a bug where the EU launch notice could fail to be shown on the first launch of the app on some devices.
  • Updated the Google Mobile Ads SDK (AdMob) version to 15.0.1.
  • Updated the YouTube Data API to version v3-rev198-1.23.0.

Andromo App Maker for Android v5.0.16 is now live at www.andromo.com.


Comments

  • By mistake, I placed the text for the GPDR at "License Agreement" instead of "Lauch Notice".

    Does the fixed bug even occured on "License Agreement" ?

    Would ist be nessesary to build and update my apps again, if I build them in Mai 2018?



  • Create Your Own App with Andromo


  • edited June 18
    The License Agreement (http://support.andromo.com/kb/application-settings/settings#license-agreement) is not the same as the Launch Notice (http://support.andromo.com/kb/application-settings/settings#launch-notice-eu-user-consent-notice-).

    The License Agreement is always shown and is designed as “accept / decline”, where “decline” exits the app. It should not be used for GDPR purposes, as exiting the app because is not an acceptable action according to GDPR.

    The Launch Notice can be enabled for EU users only and has OK as the only option. This notice is technically more for Google AdMob compliance than it is for GDPR, as Andromo since v5.0.15 automatically makes sure that anything that would record “personal data” is disabled for eu users.

    Read the blog post for step by step instructions on GDPR compliance:

    https://blog.andromo.com/2018/creating-gdpr-compliant-apps-with-andromo/


  • Hello, Something strange is happening to my recet apps. Admob Banner is not showing. There is only a white space, but the banner does not appear. Please colinadams, can you check it?
  • edited June 21
    Hello, the same thing is happening to me, a blank space is shown but the banner does not appear.
    It happens to me in all the app that I create.

    Is it an error when updating? How can we solve it ? Thank you !!!
  • There were no changes to the ad display code in this release.

    The code for showing AdMob banners is exactly the same for every activity in Andromo. If you've seen a banner ad in your app, it means everything is configured correctly as far as your AdMob Ad Unit ID goes. In the cases where you're periodically not seeing a banner ad in that app, it means that the request for an ad from AdMob failed. The most common failure is the "No fill from Ad Server" which means "The ad request was successful, but no ad was returned due to lack of ad inventory." There are other scenarios, but in all cases no ad will be shown if AdMob's server returned an error.

    In the case where you've never seen a banner ad in your app, you should set your device as a test device to show test ads which will tell you whether or not your ID is entered/configured properly. This is something you should always be doing to avoid your account being flagged due to invalid activity:

    http://support.andromo.com/kb/monetization-options/setting-up-admob...

    When your device is set as a test device in your app, you may still encounter "no fill" situations, however from my understanding it's intentional for developer testing.

    For any further information you would need to contact AdMob since they're the only ones who could give you further details about the ads being served/not served to your apps.

  • In addition, you should be aware that when you create new ad unit IDs, it can take a few hours for them to become active on AdMob and that live ads (ads that aren't test ads, or set as a test device) usually won't be served until there's enough requests/different devices. It can also sometimes take a couple minutes for ads to begin to be served the first time, or after periods of inactivity for the ad unit. You should always set your device as a test device to confirm things are working.

  • The test ads show well but the "normal" of admob not as I say, the box is blank and nothing is seen. The admob code has been created for 4 days so I do not think that is the problem.

    Thank you.
  • @applibres you should be making new AdMob id’s for every app you make. You should not be sharing the codes between apps. As we showed you in your support ticket, ads are working in your app. There just may not be fill in your country, or because you app is not up on google play. It takes time for google to send ads to your app, As Darryl explained...

    If you see test ads, then it is working.
  • I do not share admob codes between applications, I just put them to check that they worked.

    Thanks for all the attention, I will continue checking to see if it works correctly.

    A greeting.
  • Don’t be playing around with your AdMob id’s... create it and add it to your app. Don’t “try it out” somewhere else first. Don’t you think Google would find it odd/suspicious that your AdMob id is being used in different apps? I wouldn’t mess around with that if I were you.
  • Thank you very much for the advice
Sign In or Register to comment.